33 lines
964 B
Bash
33 lines
964 B
Bash
# Maintainer: Ivy Foster <iff@archlinux.org>
|
|
# Contributor: alive4ever <alive4ever at live.com>
|
|
# Contributor: Earnest
|
|
pkgname=opendoas
|
|
pkgver=6.6.1
|
|
pkgrel=2
|
|
pkgdesc='Run commands as super user or another user'
|
|
arch=(x86_64)
|
|
url='https://github.com/Duncaen/OpenDoas'
|
|
license=(custom:ISC)
|
|
depends=(pam)
|
|
install=opendoas.install
|
|
source=(
|
|
"https://github.com/Duncaen/OpenDoas/releases/download/v6.8/opendoas-6.8.tar.gz"
|
|
"https://github.com/Duncaen/OpenDoas/releases/download/v6.8/opendoas-6.8.tar.gz.sig"
|
|
)
|
|
backup=(etc/pam.d/doas)
|
|
# checksums provided by packager. Take with a grain of salt!
|
|
sha256sums=('18e4f3c191b866deda5d9b97e08b5ba4988b84e913a6a39f93565753cd8e6372'
|
|
'SKIP')
|
|
validpgpkeys=(C4B6FBA98211F7EFF35DEB73335C1D17EC3D6E35)
|
|
|
|
build() {
|
|
cd "opendoas-6.8"
|
|
./configure --prefix=/usr --with-timestamp
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "opendoas-6.8"
|
|
make DESTDIR="$pkgdir" install
|
|
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/opendoas/LICENSE"
|
|
}
|