bootsplash-theme-kescher/PKGBUILD

35 lines
1.2 KiB
Bash

pkgname='bootsplash-theme-kescher'
pkgver=0.1
pkgrel=1
pkgdesc="kescher bootsplash theme"
url="https://git.kescher.at/jeremy.kescher/bootsplash-theme-kescher"
arch=('x86_64')
license=('GPL')
optdepends=('bootsplash-systemd: for bootsplash functionality')
makedepends=('imagemagick' 'bash' 'findutils' 'coreutils')
options=('!libtool' '!emptydirs')
source=('bootsplash-packer'
'bootsplash-kescher.sh'
'bootsplash-kescher.initcpio_install'
'kescher.png'
'spinner.tar.xz')
sha256sums=('51559d3ccfb448b03fa6439faf5869dbd0c2fbda1b5d5bf5d4ba70e60937472a'
'7702099f93e2728b6874aafe3026c7b62bc3ad34470737f91085536a7d0977fe'
'42cd7e9a2b7d8905f6b21b3f9c898ec38a7a19763e3fe49a48610cdc7d6e03ed'
'c62cd264197f0b95704e991d88a6b9534b391501b763b3b9629ecec860ab7a45'
'8f6e5775a2b3909b97a1aaddda04f06d992f79f98a044a56fefb91aa77984172')
build() {
cd "$srcdir"
bash ./bootsplash-kescher.sh
}
package() {
cd "$srcdir"
install -Dm644 "$srcdir/bootsplash-kescher" "$pkgdir/usr/lib/firmware/bootsplash-themes/kescher/bootsplash"
install -Dm644 "$srcdir/bootsplash-kescher.initcpio_install" "$pkgdir/usr/lib/initcpio/install/bootsplash-kescher"
}